Diese Seite auf Deutsch anzeigen?

MailStore V22.4: Multi-Factor Authentication for the MailStore Service Provider Edition and Improved Resource Management

Release 22.4

This quarter too, we’re happy to present a new version of our email archiving software: Version 22.4 of MailStore Server, the MailStore Service Provider Edition (SPE), and MailStore Home is available right now. The new version of our MailStore Service Provider Edition supports multi-factor authentication. We’ve also improved how the software in all three products manages the available resources. It goes without saying that Version 22.4 of MailStore Server and the MailStore Service Provider Edition will also be GDPR-certified.

Overview

New Features for the MailStore Service Provider Edition, MailStore Server and MailStore Home

Find out more about the improvements you can expect in Version 22.4 of the MailStore Service Provider Edition, MailStore Server and MailStore Home.

Support of Multi-Factor Authentication for the MailStore Service Provider Edition

Once again, we’ve enhanced the security of our MailStore Service Provider Edition. Access to the management console by administrators can now be secured via multi-factor authentication. After entering a username and password, administrators are now prompted to input an access code from an authenticator app of their choice in order to be able to access the management console.

If the administrator then wishes to use the management API, a separate API password must be generated. The API password is generated in the management console and is required by every system administrator for whom multi-factor authentication has been activated. This allows the API to be used without the need to enter a second factor, e.g. for automation purposes.

Improved Resource Management for the MailStore SPE, MailStore Server, and MailStore Home

Once again, we’ve improved resource management in all three software solutions. Specifically, this means that we’ve optimized how the available memory is used when running our software.

Updated Certification: Meeting Data Privacy Requirements

As usual, the latest version of our software, Version 22.4 of MailStore Server and the MailStore SPE, has been certified by an independent data privacy expert.

The certification takes into account all relevant aspects of the European General Data Protection Regulation (GDPR) and affirms that, when used appropriately, both MailStore Server and the MailStore SPE meet all the requirements governing the processing of personal data set out in the GDPR.

You can request a copy of the official GDPR audit certificate from [email protected].

Registered MailStore partners can download the certificates from our Partner Portal or request it by email from [email protected].

Availability

You can download the new version of MailStore Server and the MailStore Service Provider Edition free of charge from our website.

If your MailStore Server Update & Support Service has expired, please contact us to purchase an upgrade that will allow you to use the latest version of MailStore Server. Read here to find out about other good reasons for having an active Update & Support Service agreement in place.

Interested companies can also download MailStore Server Version 22.4 as part of a free, 30-day trial. If you are an MSP and are interested in offering email archiving as a service based on the MailStore SPE, please contact our sales team at [email protected]. Alternatively, you can sign up as an authorized MailStore Partner with us right now for free.

Click Here for the Corresponding Changelogs

More Information

Detailed information on recent versions can be found here:

Sharing


Leave a Reply