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MailStore – “Details: Not allowed to access Non IPM item. EWS Error Code: ErrorAccessDenied.” when archiving emails from Microsoft 365

ID: 15164

Summary

When archiving from Microsoft 365 mailboxes in MailStore, the following error occurs: “Microsoft Exchange Server was unable to complete the task. Details: Not allowed to access Non IPM item. EWS Error Code: ErrorAccessDenied.”

– MailStore Server
– MailStore SPE

Cause

Microsoft has begun restricting access to Teams content via the EWS interface. Since MailStore also handles Microsoft 365 email archiving through EWS, certain adjustments must be taken into account.

Background information:

https://devblogs.microsoft.com/microsoft365dev/restricted-access-to-microsoft-teams-data-via-ews-starts-january-31-2023/

Resolution

This is a third-party issue and cannot be resolved by MailStore.

Excluding the corresponding folder “TeamsMessagesData” or “Recorded Conversations/Team Chat” could provide a suitable workaround.
The relevant folder containing the Teams chats may also have a different name on your system.

Microsoft typically skips Teams data within a mailbox when migrating from on-premises to Exchange Online,
but third-party tools were also able to migrate Teams information.