MailStore – Archiving issues with the Graph API in M365
Summary
We are currently receiving numerous requests regarding mailbox archiving via Graph with Microsoft 365 (Exchange Online).
Customers are experiencing intermittent interruptions, and delays in archiving jobs, accompanied by various error messages.
Cause
The Microsoft services, like Exchange Online are under heavy load and don’t respond within an expected time frame.
We are currently investigating the cause and preparing further possible solutions.
Resolution
Workaround
1.) Always use journal archiving for archiving emails from M365.
This is the only way to ensure that every single email is transferred to the archive in a legally compliant manner.
2.) Use mailbox archiving additionally if you also want to transfer the mailbox folder structures to the archive or delete
selected messages from the mail server mailbox.
3.) As mentioned above, mailbox archiving is currently causing irregular issues,
which we are observing specifically in connection with the Microsoft Graph API.
If necessary, temporarily disable faulty archiving profiles until a solution is available.
We are currently investigating the causes and preparing further solutions.
If a solution is available, we will make it available via the download section on our website.