MailStore – Not all mails of the Exchange mailbox are being archived when archiving an Outlook profile
Summary
In MailStore, when archiving an Outlook profile, not all mails of the Exchange mailbox are being archived, instead only messages of the last month or the last year are being archived.
Cause
Outlook can be configured to use the Exchange-Cache-Mode. Outlook then only has access to messages of a certain period in the mailbox.
When ActiveSync is used as protocol to connect to an Exchange Server, Outlook can be configured to synchronize only messages of the last month.
When archiving an Outlook profile, MailStore can only archive messages that can be accessed by Outlook directly.
Resolution
We recommend archiving directly from the Exchange mailbox without having Outlook in between !
Alternatively, disable the Exchange-Cache-Mode or increase the time span for messages that Outlook can access.
https://support.microsoft.com/en-us/kb/2733062