MailStore – Outlook Add-in – “Error Message: A problem was detected with an add-in and it has been disabled.” when open Microsoft Outlook
Summary
In Microsoft Outlook 2013 or newer, the error message “A problem was detected with an add-in and it has been disabled.” appears and the MailStore Outlook Add-in is disabled. As a result, the add-in is listed in the “Disabled Add-ins” section under, these add-ins decreased performance or caused Outlook to crash.
This issue was reported in (but may not be limited to):
- MailStore Server
- MailStore SPE
Cause
Microsoft Outlook 2013 and newer are very strict when interpreting loading times of add-ins. Therefore, the MailStore Outlook Add-In should be activated permanently. This can be configured in the Outlook options.
Resolution
Third-Party Issue
This is a third-party issue and cannot be resolved by MailStore.
In Outlook click “File”, then “Manage COM Add-ins” (Slow and Disabled COM Add-ins, see image below), and check whether the MailStore Outlook Add-In is listed. When it is listed, enable it permanently.
The Add-in can be enabled permanently by using Group Policies. The necessary steps are documented in the Microsoft article under “Add-in resiliency / Preventing add-ins from being disabled“:
https://msdn.microsoft.com/en-us/vba/outlook-vba/articles/support-for-keeping-add-ins-enabled
The ProgID of the MailStore Outlook Add-In is MailStoreOutlookAddin3.AddinModule