MailStore – EWS Error Code: “Requesting the OAuth2 token to access the mailbox has failed. Error: Keyset does not exist” when archive from Microsoft 365 mailboxes
ID: 13511
Summary
In MailStore, if you’re archiving from Microsoft 365 mailboxes, the following error occurs: “EWS Error Code: “Requesting the OAuth2 token to access the mailbox has failed. Error: Keyset does not exist”
This issue was reported in (but may not be limited to):
- MailStore Server
- MailStore SPE
Cause
This error occurs with the archiving profile. It does not affect all profiles and can always affect different mailboxes.
Resolution
You need to use a MailStore system which fulfills the system requirements, especially the CPU cores/threads.
The minimum is 4 cores, 4 threads for Journal archiving, 4 cores, 8 threads for user mailbox archiving.
MailStore help article LINK for the system requirements:
https://help.mailstore.com/de/server/Systemanforderungen