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MailStore – The Outlook Add-in is not visible

ID: 13601

Summary

In MailStore Server, although the installation of MailStore’s Outlook Add-in was successful, the add-in is not displayed in Outlook. This issue was reported in (but not limited to):

  • MailStore Outlook add-in

Cause

The issue has multiple causes.

Resolution

  • The MailStore Outlook add-in might have been disabled by Outlook, e.g. due to loading times.
    In Outlook, click File > Manage COM Add-ins (Slow and Disabled COM Add-ins) and check whether the
    MailStore Outlook Add-In is listed. When it is listed, enable it permanently.
  • Check whether the MailStore Outlook Add-In is listed in Outlook Options > Add-Ins. In case the Add-In is not listed, click Manage > COM Add-Ins > Go and verify that the Add-In entry is checked. Is the Add-In not listed in COM Add-Ins navigate to Outlook Options > Add-Ins > Manage > Disabled Items > Go and ensure the Add-In is Enabled. Afterwards, verify that the Add-In entry is checked in COM Add-Ins.
    If the Add-In is not listed in COM Add-Ins and in Disabled Items open Outlook as an administrator, navigate to Outlook Options > Add-Ins > Manage > COM Add-Ins > Go > Add… Navigate to the installation directory of the Add-In and add the file MailStoreOutlookAddin3_x64.dll or MailStoreOutlookAddin3_x86.dll, depending on the bittness of your Outlook installation.
    You may have to re-install the Add-In so the DLL files will be registered.
  • Check whether the MailStore Outlook Add-In is listed in Outlook Options > Add-Ins > Manage >COM Add-Ins > Go and Load Behavior is either “Not loaded. Certificate of signed and load at startup, COM Add-in is not in trusted source list.” or “Not loaded. The user selected to disable macros.”. In this case the user has set not set the setting Outlook Options > Trust Center > Trust Center Settings… > Macro Settings and has set Apply macro security settings to installed add-ins and has disabled the Add-In during the start of Outlook. To load the Add-In, lower the macro security and enable the Add-In during the start of Outlook or disable the setting Apply macro security settings to installed add-ins.
  • By default, the Add-In integrates into the Outlook Ribbon as main tab. Navigate to Outlook Options > Customize Ribbon > and verify that there is a MailStore entry in Main Tabs and that this entry is enabled. In case, there isn’t, you can add the Add-In with Choose commands from > Main Tabs > MailStore > Add or Customizations > Reset. You are free to adjust the Add-In according to your needs here.
  • Another reason is a corrupt Outlook profile. Try to create a new profile and see if the MailStore Outlook Add-in is displayed there.
  • Check whether the .NET framework 4.8 is installed or enabled as a feature. For example, this is not the case with Windows 7 by default.
  • Ensure you do not have disabled the MailStore Group Policy “Enable MailStore Outlook Add-In Toolbar by default“. MailStore Group Policies are stored in the registry in                                                    

    HKEY_CURRENT_USER\Software\Policies\deepinvent\MailStore Outlook Add-in 2

    These settings should not be modified manually, but only by using the MailStore ADMX templates.

  • The load behavior of the Outlook Add-In is controlled by registry keys:

When using a 64-bit Office or a 32-bit Office on a 32-bit Windows the value of the registry key

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\MailStoreOutlookAddin3.AddinModule\LoadBehavior

has to be “3″.

When using a 32-bit Office on a 64-bit Windows, the key can be found in the path

HKEY_LOCAL_MACHINE\SOFTWAREWOW6432Node\Microsoft\Office\Outlook\Addins\MailStoreOutlookAddin3.AddinModule\LoadBehavior

and the value has to be “3”.

In case these keys exist in:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\Outlook\Addins\MailStoreOutlookAddin3.AddinModule\LoadBehavior

the keys in HKEY_LOCAL_MACHINE will be preferred and have to be adjusted to “3” there.

Registry Keys

Alternatively to creating all registry entries manually, you can create a registry file and import the settings that way.

Please copy the following registry keys via copy button into a text editor. Save the document as a .reg file.
Afterwards, double-click on the .reg file you have created.

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\Outlook\Resiliency\AddinList]
"MailStoreOutlookAddin3.AddinModule"="1"
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\Outlook\Addins\MailStoreOutlookAddin3.AddinModule]
"LoadBehavior"=dword:00000003
[-HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\Resiliency\DisabledItems]
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\Resiliency\DisabledItems]
[-HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\Resiliency\CrashingAddinList]
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\Resiliency\CrashingAddinList]
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\Resiliency\DoNotDisableAddinList]
"MailStoreOutlookAddin3.AddinModule"=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Office\Outlook\Addins\MailStoreOutlookAddin3.AddinModule]
"LoadBehavior"=dword:00000003
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Outlook\Resiliency\AddinList]
"MailStoreOutlookAddin3.AddinModule"="1"
[-HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\15.0\Outlook\Resiliency\DisabledItems]
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\15.0\Outlook\Resiliency\DisabledItems]
[-HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\15.0\Outlook\Resiliency\CrashingAddinList]
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\15.0\Outlook\Resiliency\CrashingAddinList]
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\15.0\Outlook\Resiliency\DoNotDisableAddinList]
"MailStoreOutlookAddin3.AddinModule"=dword:00000001