MailStore Outlook Add-in – Opening an attachment may return an error indicating the attachment is write-protected
Summary
After opening and closing an email attachment in the email preview of the MailStore Outlook Add-in, attempting to open the same attachment again may result in the attachment being shown as write-protected in the client application (e.g., Excel, Word, etc…).
Cause
This behavior results from the MailStore Outlook Add-in’s internal browser control opening multiple handles on the temporary attachment file and not releasing these handles in a timely fashion.
Resolution
You can restart Outlook to release the lock immediately.
Alternatively you can open the message using the MailStore Outlook Add-in’s toolbar button, then open the attachment within Outlook’s email dialog to access the attachment immediately.
Additional Information
MailStore’s Outlook Add-in relies upon the internal browser functionality of Outlook, which itself is based on the IE browser control, and this cannot be influenced by the Outlook Add-in.