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MailStore – Microsoft Exchange Server returned an unexpected EWS error: “The SMTP address has no mailbox associated with it” with failure code “ErrorNonExistentMailbox” when archive emails from a Microsoft Exchange Server 2013

ID: 13521

Summary

In MailStore, if you archive emails from a Microsoft Exchange Server, the following EWS error occurs: “The SMTP address has no mailbox associated with it” and failure code “ErrorNonExistentMailbox”.

This issue was reported in (but may not be limited to):

  • MailStore Server
  • MailStore SPE

Please note: Independent of this global property, MailStore is neither able to archive messages (where the above error occurred), nor delete them from the Exchange Server.

Cause

The cause of this problem is a bug in Microsoft Exchange Server 2013.

Resolution

Third-Party Issue
This is a third-party issue and cannot be resolved by MailStore. This bug in Microsoft Exchange Server 2013 has been resolved with the Cumulative Update 8. More details can be found here:
https://support.microsoft.com/en-us/kb/3006861

This error can also occur in Microsoft Exchange 2007 and Microsoft Exchange 2013 hybrid installations if the MailStore Service account is lacking “ApplicationImpersonation” permissions on one of the Exchange servers. These permissions have to be assigned explicitly on both an Exchange 2007 CAS and on a Microsoft Exchange 2013 CAS, as detailed in our implementation guides.
These guides can be found here:

Microsoft Exchange Server 2007: How to set up a central user for accessing mailboxes:
https://help.mailstore.com/en/server/index.php?title=Archiving_Emails_from_Microsoft_Exchange_2007

Microsoft Exchange Server 2013: How to set up a central user for accessing mailboxes
https://help.mailstore.com/en/server/index.php?title=Archiving_Emails_from_Microsoft_Exchange_2013