MailStore – Login Error message “A Specified Logon Session Does Not Exist”
ID: 13566
Summary
When you start the MailStore Server and the service does not start or the SSL/X509 certificate cannot be selected. The error message “A specified login session does not exist. It may have already been terminated”, occurs.
Cause
The error is caused by a certificate issue.
- The MailStore Server service does not start, because the SSL/X509 certificate matching private key should be used.
- The certificate cannot be selected in MailStore Service configuration because it is not displayed.
Resolution
This is a third-party issue and cannot be resolved by MailStore.
Review issues with certificates
If you have an issue with certificates, you’ll have to do further investigation. First you have to get the subjects, serial numbers and fingerprints of the installed certificates to identify which certificate is used by MailStore.
- Open PowerShell and enter the following command:
Get-ChildItem Cert:LocalMachineMy | select Subject, Serialnumber, Thumbprint, HasPrivateKey
- Try to repair the certificate store with the following command:
certutil -repairstore my SerialNumber
- Serial Number is the serial number of the certificate that should be used.
- Verify that the service starts successfully now.
- If this does not resolve the issue, import the certificate again or use the MailStore Server Service Configuration to create a new certificate.
- Make sure that the certificate is being imported in the computer’s personal certificate store and that the certificate file includes the private key.