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MailStore – “EWS Error Code: ErrorMimeContentConversionFailed” when archive email from a Microsoft Exchange Server or Microsoft 365

ID: 13411

Summary

In MailStore, if you archive emails from a Microsoft Exchange Server or Microsoft 365, the following EWS error occurs: “Microsoft Exchange Server was unable to complete the task. Details: MIME content conversion failed. EWS Error Code: ErrorMimeContentConversionFailed”

This issue was reported in (but may not be limited to):

  • MailStore Server
  • MailStore SPE

Please note: Independent of this global property, MailStore is neither able to archive messages (where the above error occurred), nor delete them from the Exchange Server.

Cause

The error is caused by an internal Exchange Server error. The Exchange Server is not able to convert the internal MAPI format used by Exchange into RFC822 compliant MIME format, which is used by MailStore.

Resolution

In nearly all cases, the original MIME message received by the Exchange server already contained invalid data, such as an appointment request confirmation without references to the original appointment. Therefore, it is usually safe to delete those emails.

Due to that error, the archiving profile itself terminates with a non-successful status code. This behavior can be changed since MailStore Server 8 by modifying the global property public.arcclient.skipMimeContentConversionFailed.

Please execute the following command in the MailStore API Management Shell:

store-setprop --name="public.arcclient.skipMimeContentConversionFailed" --value="true"