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MailStore – “EWS Error Code: ErrorItemNotFound” when archive email from a Microsoft Exchange Server or Microsoft 365

ID: 13582

Summary

In MailStore, if you are archiving from Microsoft 365 mailboxes, the following error occurs: “EWS Error Code: ErrorItemNotFound”

This issue was reported in (but may not be limited to):

  • MailStore Server
  • MailStore SPE

Cause

The issue has multiple causes.1: This problem can Something went wrong with an initial migration, leaving incomplete or incorrect records for some mailboxes.2: You are using a loadbalancer in front of your Exchange servers. Due to the replication mechanism, the mailbox databases on the Exchange servers are not always identical. MailStore tries to fetch messages headers of IDs which have been received from another server, which are not present on the currently queried server.

Resolution

Third-Party Issue1: This is a third-party issue and cannot be resolved by MailStore. If you have issues with a mailbox and want to fix it by moving the mailbox within your Exchange Online organization, please open a Microsoft Support request.2: This is a third-party issue and cannot be resolved by MailStore. Configure the archiving profile to connect directly to one of the Exchange servers instead of connecting to the loadbalancer or make sure the loadbalancer is not switching between servers during a session.

Due to that error, the archiving profile itself terminates with a non-successful status code. This behavior can be changed since MailStore Server 10 by modifying the global property public.arcclient.skipEwsErrorItemNotFound by executing the following command in MailStore’s Management Shell:

store-setprop --name="public.arcclient.skipEwsErrorItemNotFound" --value="true"

Please note: Independent of this global property, MailStore Server is neither able to archive messages where the above error occurred nor delete them from the Exchange server.